Cara konfigurasi IPCOP 2.0.3 sebagai transparent proxy Mikrotik

May 13, 2013 § 9 Comments

silahkan cari refrensi tentang instalasi ipcop 2.0.3
perlu dijelaskan bahwa tentang add on advance proxy yang hanya bisa di install di dalam ipcop versi 1.4.x tidak kemudian menjadikan add on advance proxy tidak bisa di install di 2.0.3, karena advance proxy sudah built-in di dalam versi 2.0.3
silahkan download di sini http://www.ipcop.org/download.php

anda bisa cari di web bagaimana menginstall ipcop 2.0.3

catatan : pada saat instalasi pastikan ada 2 lan card, (meskipun pada saat pengimplementasian, anda hanya menggunakan 1 lancard) kenapa pada saat instalasi harus ada 2 lan card? bisa dibaca disini http://www.ipcop.org/docs.php
berikan ip green sesuai dengan topologi jaringan yang terhubung dengan router mikrotik anda.

setelah anda berhasil menginstall, sekarang saat nya anda mengkonfigurasi ipcop sebagai transparent proxy mikrotik.

377236_550284954993668_1168567144_n

dengan menggunakan proyeksi ip address
(catatan : ip gambar diatas mohon diabaikan, karena tidak sesuai dengan ip yang akan saya jelaskan, namun posisi topologi jaringannya yang saya maksudkan adalah seperti gambar diatas)

ip proxy menuju mikrotik 192.168.15.15/24
ip mikrotik menuju proxy 192.168.15.1/24
ip mikrotik menuju LAN 192.168.0.1/24

  1. buatlah nat Masquerade mikrotik dan proxy

    /ip firewall nat add chain=srcnat action=masquerade out-interface=ether_proxy
    /ip firewall nat add chain=srcnat action=masquerade src-address=192.168.15.0/24  out-interface=ether_internet

  2. pastikan anda sudah berhasil melakukan ping dari mikrotik ke proxy di terminal mikrotik anda. (jika belum berhasil ping, harap jangan melanjutkan langkah selanjutnya)
  3. buka browser anda dan ketikan 192.168.15.15:8443 untuk melakukan konfigurasi dari web interface ipcop
    Imagepastikan anda mengingat user dan password web interface pada saat installasi awal ipcop 2.0.3
  4. pilih tab service, lalu proxy
    Image
    seperti gambar diatas.
  5. pastikan tidak ada yang telewat dari settingan dibawah ini
    Image
    centang tanda enable on GREEN
    proxy port sesuaikan keingan anda, saya menggunakan 3128
    centang tanda transparent on GREEN
  6. scroll lagi kebawah.
    Image
    jangan lupa untuk mencentang disablee internal proxy access to green from other subnet.
    network based access control ini silahkan isi range ip yang akan terkoneksi dengan proxy anda,
    192.168.0.0/24 ini range ip LAN
    192.168.15.0/24 ini range ip proxy
    hardisk cache ini kurang lebih sediakan sekitar 60% dari total hardisk yang anda pakai pada mesin ipcop
  7. save.
  8. konfigurasi nat agar trafik di mikrotik dipaksakan belok dulu ke mesin proxy,

    /add firewall nat add chain=dstnat action=dst-nat to-addresses=192.168.15.15 to-ports=3128 protocol=tcp src-address=!192.168.15.0/24 dst-port=80,8080,81,3128,9988,8899

  9. silahkan anda cek, apakah ethernet proxy anda sudah terlihat terlewati trafik, jika sudah berarti anda sudah berhasil
    Image
    saya menggunakan ether 2 sebagai ether yang menuju proxy dalam percobaan ini
  10. untuk meyakinkan anda apakah proxy ipcop sudah bekerja, silahkan buka web config ipcop, service-> proxy, centang log enable, lalu save.
    masuk kedalam mesin proxy ipcop anda melalui putty.
    Image
    masuk ke putty, isikan address 192.168.15.15 port 8022. lalu open. isikan user dan password sesuai saat anda membuatnya ketika instalasi ipcop.
    ketikan perintah pada terminal

    tail -f /var/log/squid/access.log

    Image
    jika sudah terlihat seperti diatas, maka proxy anda sudah bekerja.
    catatan : perlu anda ketahui bahwa ketika anda mencoba mengakses http://www.lagado.com/proxy-test dan ternyata tidak diketemukan infromasi sebagaimana anda menggunakan sebuah proxy, tenang. yang penting access.log anda jalan. :) be happy.
    jika merasa log tidak begitu penting karena akan membebani proxy menyimpan log, maka kembalikan posisi enable log tidak tercentang.

  11. langkah berikutnya adalah mem-bypass semua paket yang sudah ter-cache didalam proxy agar tidak terlimit untuk bisa sampai ke komputer klien.

      /ip firewall mangle add chain=prerouting action=mark-packet new-packet-mark=proxyhit passthrough=no dscp=12/ip firewall mangle add chain=forward action=mark-packet new-packet-mark=proxyhit  passthrough=no layer7-protocol=HIT in-interface=ether_proxy out-interface=ether_klien

    /queue tree add name=”bypass” parent=global-out packet-mark=proxyhit limit-at=100k queue=default priority=1 max-limit=10M burst-limit=0 burst-threshold=0 burst-time=0
    catatan : buatlah layer-7 protocol dengan nama HIT dengan regexp codenya adalah =

    http/(0\.9|1\.0|1\.1)[\x09-\x0d ][1-5][0-9][0-9][\x09-\x0d -~]*(x-cache: hit)

  12. selesai.
  13. ucapakan alhamdulillah.

jika ada pertanyaan silahkan ajukan pertanyaan. :)

khusus setingan bypass HIT yang optimal saya masih belum bisa menemukan yang pas. tapi untuk artikel dibawah ini perlu anda coba :)

http://www.forummikrotik.com/guide/11215-[share]-teknik-lain-proxy-hit.html

 

catatan : kesulitan setting transparent proxy adalah ketika>

1. membypass semua akses dari eth proxy ke eth klien.
jadi akan muncul keanehan ketika data yang kita minta belum tersedia di proxy, maka proxy akan mengambil dari internet. nah ini yang menyebabkan situasi mangle di mikrotik jadi berantakan. sehingga limit klien tidak bekerja sesuai  dengan harapan.

saat ini saya sedang serius mencari jalan keluar permasalahan yang umum terjadi pada transparent proxy.

About these ads

Tagged: , ,

§ 9 Responses to Cara konfigurasi IPCOP 2.0.3 sebagai transparent proxy Mikrotik

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

What’s this?

You are currently reading Cara konfigurasi IPCOP 2.0.3 sebagai transparent proxy Mikrotik at Hey, Awik.

meta

Follow

Get every new post delivered to your Inbox.

Join 27 other followers

%d bloggers like this: